SPContentDatabaseSequence cannot upgrade an object whose build version is too old

Today I was trying to do a database upgrade of SharePoint 2007 to SharePoint 2010, to do this Mount-SPContentDatabase CmdLet should be executed which upgrades the database, while trying to run it, I got the following error:

Mount-SPContentDatabase : Sequence [Microsoft.SharePoint.Upgrade.SPContentDatabaseSequence] cannot upgrade an object [SPContentDatabase Name=WSS_Content] whose build version [12.0.0.4518] is too old. Upgrade requires [12.0.0.6421] or higher.
At line:1 char:24
+ Mount-SPContentDatabase <<<<  -Name WSS_Content_Main_Portal -DatabaseServer d
-WebApplication
+ CategoryInfo          : InvalidData: (Microsoft.Share…ContentDatabase:
SPCmdletMountContentDatabase) [Mount-SPContentDatabase], SPUpgradeExceptio
n
+ FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletMountCon
tentDatabase

After googling a little bit, I found out that the content database which I was to trying to upgrade was a backup before SharePoint 2007 SP2 was installed, check the version from SharePoint 2007 Central Administration, Operations, Servers in Farm (under topology and services), version should be minimum 12.0.0.6421.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s