Getting authentication prompt again and again while trying to access #SharePoint 2010 Rest Interface

While trying to access to ListData.svc service in a SharePoint 2010 sub site I was getting authentication prompt to enter credentials again and again. I was using a SharePoint Farm administrator account so was sure that permission is not the cause of this problem. So I started SharePoint Manager, browsed to the sub site and saw that there was a problem in a feature

SharePoint Manager Site Feature List

Afterwards I checked in the list nodes of the same site to see which lists were included in this missing feature, after clicking on one of the lists I got the following error which hinted that this list was the one included in the feature.

SharePoint Orphaned list exception

Further in the properties window there was an error message in the content type field

SharePoint Manager List Properties

I deleted this orphaned lists and the service worked fine then.

I hope you found this post helpful. Thanks

Advertisements

3 thoughts on “Getting authentication prompt again and again while trying to access #SharePoint 2010 Rest Interface

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s